Raspberry Pi 3でのGUI開発 – Anjuta

津路です。

Anjuta
IDEです。最後の更新が2015年となっています。
GNU General Public Licenseです。
OSの管理ソフト上では、3.14が見つかりました。
sudo apt-get update
sudo apt-get install anjuta libgtk-3-dev
で、以下のメッセージが出ました。

libgtk-3-devは最新版です。
インストールすることができないパッケージがありました。おそらく、ありえない状況を要求したか、必要なパッケージがまだ作成されていなかったりIncomingから移動されていないことが考えられます。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージには満たせない依存関係があります:
anjuta : 依存:libdevhelp-3-3 (>= 3.12.0-2~) しかし、インストールされようとしていません
依存:libwebkit2gtk-3.0-25 (>= 2.0.2) しかし、インストールされようとしていません
E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

以上のエラーは、過去に devhelpを入れようとしたときに見た気がします。
そこで、以下のコマンドで解決を試みようと、発行してみました。
sudo aptitude install anjuta
以下のパッケージには満たされていない依存関係があります:
libwebkit2gtk-3.0-25 : 依存:libjavascriptcoregtk-3.0-0 (= 2.4.9-1~deb8u1+rpi1) [1:2.4.1-1rpi53rpi1g が既にインストール済みです]
以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを現在のバージョンに一時固定する:
1) anjuta [インストールされていません]
2) libdevhelp-3-2 [インストールされていません]
3) libwebkit2gtk-3.0-25 [インストールされていません]

この解決方法を受け入れますか?[Y/n/q/?]
ここで、yを押すと、gnome-user-guide{a} libyelp0{a} yelp{a} yelp-xsl{a}
がインストールされました。
次に、環境をアップグレードします。sudo apt-get upgrade
sudo apt-get dist-upgrade

dist-upgradeでは、python3関係が8個インストールされました。
この後、再度 anjutaをインストールしようとしましたが、依存関係エラーが同じ内容のままです。(当然)

これ以上は細かいことをせず、最新版のanjutaをソースからインストールすることにしました。
anjuta.orgから、バージョン3.18のtarball をダウンロードし、
anjuta.orgのビルドページには、buildshを使ったほうがいいよと書いてありますが、ダウンロードした内容からすると、anjuta.buildshrcファイルが見つかりませんので、./configureから始めました。
ここで、flexが必要になりました。
INSTALLファイルにいろいろ書いてあるのですが、とりあえず、重要なものを入れてから、makeします。そして止まるたびに追加します。必要だったのは、bison, libgdl, libgda, gtksourceview, itstoolなど。
configureが成功すると、make、make install(管理者権限が必要)をします。

さて、起動しましたら、autogenが入ってないよと怒られました。
これも、依存関係に時間をかけたくなくて、最新の5.16.2をダウンロードしてソースからビルドしました。
anjuta起動後、簡単に触ってみましたが、ヘルプメニューで固まってしまいます。
プロジェクト作成は次回に。